ScootPad’s new design and features work best with the following supported browsers:

Internet Explorer 9+

Download/Upgrade IE: http://www.microsoft.com/windows/Internet-explorer
If you are using IE 8 or older versions, please upgrade your IE browser to the latest version. Support for the five-year-old Internet Explorer 8 will be dropped completely by Microsoft

Google Chrome 11+

Download/Upgrade Chrome: http://www.google.com/chrome

Firefox 5+

Download/Upgrade Firefox: http://www.mozilla.com/firefox

Safari 4+

Download/Upgrade Safari: http://www.apple.com/safari/download

How to check if you have a supported browser?

Sign In to ScootPad and click the “Help” button from the top panel and choose the “System Check” option. You’ll see if your system is supported and the recommended next steps.

Learn more about the minimum system requirements to use ScootPad?

Should you have any further questions, click the Help button and contact our support team.

Cheers,
ScootPad Team